Mr. Bro
Менеджер подій
БЕЗКОШТОВНО

OC серверID: oc-29092

Якщо Ви бажаєте знайти модулі, котрі будуть максимально сумісні з версією інтернет магазину, а також звертаєте увагу на якість коду, то пропонуємо до перегляду: менеджер подій, це рішення було розроблено спеціально для магазинів, працюючих на платформі OpenCart, з підтримкою від нашої компанії кожного магазину, що працює на CMS Brocart.



При завантаженні безкоштовного доповнення, ми не даємо 100% гарантії, що воно буде працювати на Вашому магазині, просимо бути уважними до інструкцій по встановленню!
Now you can manage your Opencart Events. I am sure you all have heard that opencart Added events to alter its output without using VQmod/OCmod. This is a very nice feature, yet it is thought to be quite new and a bit complicated. Probably because of no admin panel and little to no documentation.

DEMO 2.2.0.0

View code on GITHUB


We have created this module for everybody to get a grasp on Events and the unlimited possibilities.
- You can alter the output of your Models
- You can edit your HTML with any simple dom or any other dom manipulation class.
- You can add more vars to your Controller Data

and much more.

We also wanted to add the EVENT features to old Opencart stores. So with this module you can install an OCmod compatibility option for old stores bellow 2.3.0.0. Simply go into admin -> tab Settings and click enable compatibility.

INSTALLATION
1. First install shopunity module from https://shopunity.net
2. Activate shopunity module
3. Install Event manager
4. Activate Event manager
5. If you have 2.2.0.0 or bellow go to Tab Settings in Event manager and Activate compatibility option.

FEATURES
1. Edit your events
2. Enable/Disable events
3. Activate compatibility for 2.2.0.0 and bellow.

COMPATIBILITY
Almost all the features have been ported to the old opencart versions so you can use Events just like you would have used them in Opencart 2.3.0.x Only Catalog/Model/Total classes will not be supported since they use referals and proxy/callback doesn't support this. But for everything else it is pretty much the same.

The compatibility is install via OCmod. Shopunity is required.

TESTING
We also add a test to see if your events actually work. Click install test and you will see test events and their status in tab Settings. If all good, they should all pass the test.

SUPPORT
If you need support - send us a ticket and we will help.